Technical Requirements for viewing Videos

System Requirements for viewing, browsing, and apps

Qasid Online primarily uses the Vimeo player for hosting its videos. While the Vimeo player may work on older setups, we strongly recommend keeping your system as up to date as possible. Browsers and operating systems are constantly releasing bug fixes, security updates, and improvements, and it’s our responsibility to keep up with them as well. Using the latest browser version can always help to prevent weirdness with Vimeo and the Interwebs at large.

Below you’ll find our minimum requirements for vimeo.com, playback, and apps.

Supported browsers — playback

We support playback in browsers that can decode H.264 videos in an HTML5 player. Due to rising security vulnerabilities, Vimeo no longer supports Flash. If you’re using an older browser, system, or website, you’ll need to upgrade to continue watching Vimeo videos.

Here is a list of our supported browsers/versions:

  • Chrome 30+ (has automatic updates)
  • Firefox 27+ (has automatic updates)*
  • Internet Explorer 11*
  • Microsoft Edge
  • Safari 9+ 


How did we do?


Powered by HelpDocs